Der 'Microsoft.ACE.OLEDB.12.0'-Provider ist nicht auf dem lokalen Computer registriert.

Achtung! Die hier beschriebenen Informationen sind veraltet. Bitte lesen Sie den Artikel "Lösungen bei Problemen mit der Microsoft Access Database Engine 64-Bit-Version" und folgen den dort beschriebenen Lösungen.



Beschreibung

Nach der Installation und dem ersten Start von Zeta Producer erscheint der Fehler:
Der 'Microsoft.ACE.OLEDB.12.0'-Provider ist nicht auf dem lokalen Computer registriert.


Ursache

Zeta Producer wird ab Version 15.2 auf einem 64-Bit-Betriebssystem als 64-Bit-Programm installiert. Die erstellten Website-Projekte verwenden eine Microsoft Access Datenbank (MDB) und benötigen daher die Microsoft Access Database Engine. Diese muss als 64-Bit-Version installiert werden. Sind jedoch 32-Bit-Version von Microsoft Office auf dem Computer installiert, kann es zu der Fehlermeldung kommen, da Microsoft keine Unterstützung für die parallele Installation von 32- und 64-Bit-Versionen von Microsoft Office oder deren abhängigen Komponenten unterstützt.


Lösungen

Tritt der Fehler bei Ihnen auf, probieren Sie nacheinander eine der nachfolgenden Lösungen aus.

1. Zeta Producer als Administrator installieren

Installieren Sie Zeta Producer als Administrator. Machen Sie hierfür einen Rechtsklick auf die Datei "zp15-setup.exe" und wählen den Eintrag "Als Administrator ausführen" aus dem Kontextmenü.

2. Microsoft Office als 64-Bit-Anwendung installieren

Installieren Sie Microsoft Office als 64-Bit-Anwendung. Führen Sie ggf. nach der Installation das Setup von Zeta Producer erneut aus.

3. Microsoft Access Database Engine 64-Bit manuell installieren

Versuchen Sie die mitgelieferte Microsoft Access Database Engine 2010 als 64-Bit-Version manuell zu installieren.

  1. Öffnen Sie dazu im Windows-Explorer das Verzeichnis C:\Users\*Benutzername*\AppData\Local\Zeta Producer 15\Applications\
  2. Führen Sie die Datei "AccessDatabaseEngine_X64.exe" als Administrator aus.

Erscheint bei der Installation eine Fehlermeldung "You cannot install the 64-bit Version of Microsoft Access Database Engine...", können Sie versuchen eine neuere Version der Microsoft Access Database Engine zu installieren:

4. Patch installieren

Sind die oben genannten Lösungen nicht möglich oder haben keinen Erfolg gebracht, können Sie den 32-Bit-Patch für Zeta Producer installieren. Dieser wandelt Zeta Producer von einem 64-Bit-Programm in ein 32-Bit-Programm um.

Gehen Sie folgendermaßen vor:

  1. Laden Sie die Patch-Datei runter: Zeta-Producer-Download Patch-Datei
  2. Führen Sie die Datei "zp-patch32bit.exe" als Administrator aus.

Es kann sein, dass Sie vor dem Ausführen des Patches das Windows-Feature ".NET Framework 3.5" installieren müssen. Erscheint die Meldung, klicken Sie bitte einfach auf "Feature herunterladen und Installieren". Führen Sie anschließend nochmals die Datei "zp-patch32bit.exe" als Administrator aus.


Hinweis zu Office 2010 32-Bit

In wenigen Fällen wurde uns von Kunden berichtet, dass nach der Installation von Zeta Producer 15.2 die installierten Anwendungen von Microsoft Office 2010 32-Bit fehlerhaft ausgeführt werden.

Ursache hierfür ist vermutlich die Installation der Microsoft Access Database Engine 2010 in der 64-Bit-Version.

Sollten dieses Verhalten bei Ihnen auftreten, hilft folgendes Vorgehen:

  1. Zeta Producer 15.2 neu installieren.
  2. Den 32-Bit-Patch ausführen.
  3. In den Windows-Einstellungen unter "Apps" die "Microsoft Access database engine 2010 (English)" deinstallieren.
  4. Eine Anwendung (z.B. Word) von Office 2010 32-Bit öffnen.
    Normalerweise wird dann Office automatisch neu konfiguriert.
    Alternativ können Sie auch das Setup von Office 2010 32-Bit ausführen und dort die Reparieren-Funktion ausführen.

Die Anwendungen von Office 2010 32-Bit sollten dann wieder problemlos funktionieren.